Mantis Bugtracker

Viewing Issue Advanced Details Jump to Notes ] View Simple ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0000265 [EvoERP] major always 2013-02-11 14:38 2013-02-19 15:23
Reporter kevind View Status public  
Assigned To
Priority normal Resolution fixed Platform
Status resolved   OS Windows
Projection none   OS Version XP Pro SP3
ETA none Fixed in Version Product Version
  Target Version Product Build 10/11/12
Summary 0000265: Error message when Epaying a voucher
Description Sometimes, when epaying a voucher, a the error message:
   GL Post date greater than check date.
   This payment will be skipped. Do you wish to continue?
is displayed.

Pressing YES or NO causes undesirable results.
Steps To Reproduce 1. Entered a Vendor Invoice (AP-C) Dated 2-5-13. GL Post Date was set to today (2-11-13) so that the receivers would show up.
2. Selected appropriate line items and finished out AP-C without error.
3. Pick Vouchers/Invoices to pay (AP-F)
4. Selected the above entered invoice.
5. Clicked Epay. The program chained to another one (I don't remember which)
6. Selected a Checking account, Set the Check Date to 2-6-13 (it was charged on that day by the vendor)
7. Got the error Message regarding the GL Post Date referenced above.
8. Selected Yes.
9. It then asked for the print template to print the epay receipt.
10. After accepting the default, a epay receipt is displayed with only headers and no payment data.
11. Closing that displays a Processing Data dialog box with the blue bouncing progress indicator.
12. A 'WARN ERR - File T7APH.SRC Line 1847' dialog box is immediately displayed with the content 'There is no active Record in the File so you cannot Delete it'
13. After Clicking OK, another error dialog is displayed with Btrieve Error file BKAPCHKF - 43.
14. Clicking OK clears that dialog box.
Additional Information The Final results of this are:
1. Payables aging is OK. Payment is reflected with the desired date (2-6-13)
2. Check register for the selected checking account is OK. Shows up on the correct date 2-6-13.
3. There are NO GL TRANSACTIONS in the GL BATCH.
4. I manually added a Credit to the Checking Asset Account and a Debit to Payables both of them Dated 2-6-13.


Clicking NO to the first error referenced in item 7 above also causes problems, but I can't remember what they were.
Tags No tags attached.
Enhancement Date
Error Message See above
Program Name AP-F 9/6/12 (problem occurs when processing Epay)
Repeatable in Test Company
Attached Files

- Relationships

-  Notes
(0000328)
kevind (reporter)
2013-02-11 16:52

In addition, the voucher is still flagged as selected for payment. I know this because I went into Pick voucher/invoices to pay, entered this vendor code and the warning that 'selections have already been made, do you want to clear these' comes up.
(0000329)
kevind (reporter)
2013-02-12 15:57

In the case of clicking epay, where you are just paying 1 vendor and there are no other payments to continue with, it may be more appropriate to display the error that the check date is before the GL Date (and that the payment will be skipped) in a dialog box with just an OK button. That way, it can just go back to the Voucher select screen so that you can do it all again.

In the case of printing checks, and there is a GL Post date greater than the check date, I would expect the YES/NO dialog box. Yes should skip the vendor with the date problem, and No should just stop processing checks and exit as if no checks had been processed.

BTW- There may be a boundry problem. I seem to remember having a check date equal to a GL Post Date and I got this error doing epay (UNCONFIRMED).
(0000332)
JEMM (developer)
2013-02-19 15:22

Fixed in T7APF and T7APH with ISTS Enhancement date of 02/12/13 or later. Invoices with bad dates are properly omitted during the posting.
(0000333)
JEMM (developer)
2013-02-19 15:23

Fixed in T7APF and T7APH with ISTS Enhancement date of 02/12/13 or later. Invoices with bad dates are properly omitted during the posting.

- Issue History
Date Modified Username Field Change
2013-02-11 14:38 kevind New Issue
2013-02-11 14:38 kevind Error Message => See above
2013-02-11 14:38 kevind Program Name => AP-F 9/6/12 (problem occurs when processing Epay)
2013-02-11 16:52 kevind Note Added: 0000328
2013-02-12 15:57 kevind Note Added: 0000329
2013-02-19 15:22 JEMM Note Added: 0000332
2013-02-19 15:23 JEMM Note Added: 0000333
2013-02-19 15:23 JEMM Status new => resolved
2013-02-19 15:23 JEMM Resolution open => fixed


Mantis 1.1.2[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker