Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0000471 [Both Evo and DBA Classic] tweak sometimes 2017-02-08 06:16 2017-08-17 10:47
Reporter dwaldmann View Status public  
Assigned To lpantic
Priority normal Resolution fixed  
Status resolved   Product Version 2017.1
Summary 0000471: "Update to latest program" does not
Description I have so far found two programs that are ignored:

T6ARE
BKSOE

I suspect there are more.
Additional Information
Tags No tags attached.
Enhancement Date
Error Message
Program Name
Repeatable in Test Company
Attached Files

- Relationships

-  Notes
(0000751)
dwaldmann (reporter)
2017-02-08 07:01

Also, I was just looking for something else on the menu and noticed that WO-E is calling for t67woe.rwn. We've never even used WO-E so I don't think it was me who changed it.
(0000752)
ISTech (administrator)
2017-02-08 10:03

Currently running the 2017.1 with all patches installed. The T6ARE is no longer supported. In EVO the Admin is using the T7ARE.RWN so if you update to latest program it should update your menu to the new T7ARE program. The admin menu is also using the T7SOE so if you update to latest program it should update the menu to use the T7SOE. You should log out of coarse and back in to see the changes. WO-E is also using the T7WOE. If your menu is calling for T67WOE.RWN then that sounds like someone edited your menu if everyone's menus are calling that out then perhaps someone used "Change Prg Name". But at this point all three programs are using the T7 versions. So if you update to latest program it should update to those.

(0000753)
dwaldmann (reporter)
2017-02-08 14:02

This has been my process:

After installing update, "log in as ADMIN once to rebuild the menu." per step 5 of the instructions.

Then log back in as myself (not an "A" type account) and use the program as is for a while. Maybe try a new/fixed program here and there (from UT-A). Eventually I copy my current menu structure as an archive, and run Update to Latest on my regular login.

I ran the Update program at least twice on my current login since the update, and still had BKSOE and T6ARE on the menu.

However, I just ran Update to Latest on my regular login WHILE logged in as Admin and it seemed to work properly.

When logged in as myself it DID update some (maybe most, but definitely not all).
(0000754)
ISTech (administrator)
2017-02-08 14:07

When you were logged in as yourself and you updated to latest Prg did you then log out and back in to see the changes? Also in PS-G just to cover our bases and make sure we didn't miss anything do you have a menu setup for yourself? When you log in as ADMIN is the ADMIN menu using the T7 Screens or the BK and T6 on your system.

The problem is we can not duplicate the issue.

(0000755)
dwaldmann (reporter)
2017-02-08 16:09

After I ran the Update program I logged out and logged back in, and didn't see any changes on my personal login.

When I ran it as the Admin, I could see the changes in PS-G right away, and they were effective when I logged out and then back in personally.

We do not have a menu called ADMIN, The ADMIN login is just set to security code "A". When I log in as ADMIN it uses all the T7 screens, as far as I can tell.

I've been doing a lot of experimenting this afternoon. All I can conclude is that the Update program does not work consistently.

Sometimes it updates some programs, sometimes it does none, and twice in a row it even changed bksoe.rUn to bksoe.rWn! I have run it dozens of times, either from the ADMIN login or my personal one, and I even deleted my "normal" login, created a new one by copying my most recent archived one, and all I get is inconsistent results. Once I could not log in at all - I got an error, IIRC it was on line 1024 after entering my credentials. That was when I deleted my menu and made a new one.
(0000758)
ISTech (administrator)
2017-02-15 11:38

I duplicated the issues running 2017.1 update with all patches installed.
(0000815)
ISTech (administrator)
2017-08-17 10:47

Problem has been fixed in latest patch released on 08/17/2017 running 2017.2 update.

- Issue History
Date Modified Username Field Change
2017-02-08 06:16 dwaldmann New Issue
2017-02-08 06:16 dwaldmann Issue Monitored: dwaldmann
2017-02-08 07:01 dwaldmann Note Added: 0000751
2017-02-08 10:03 ISTech Note Added: 0000752
2017-02-08 10:03 ISTech Assigned To => ISTech
2017-02-08 10:03 ISTech Status new => closed
2017-02-08 14:02 dwaldmann Note Added: 0000753
2017-02-08 14:02 dwaldmann Status closed => feedback
2017-02-08 14:02 dwaldmann Resolution open => reopened
2017-02-08 14:07 ISTech Note Added: 0000754
2017-02-08 16:09 dwaldmann Note Added: 0000755
2017-02-15 11:38 ISTech Note Added: 0000758
2017-02-15 11:38 ISTech Assigned To ISTech => lpantic
2017-02-15 11:38 ISTech Status feedback => confirmed
2017-02-15 11:47 ISTech Status confirmed => assigned
2017-08-17 10:47 ISTech Note Added: 0000815
2017-08-17 10:47 ISTech Status assigned => resolved
2017-08-17 10:47 ISTech Resolution reopened => fixed


Mantis 1.1.2[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker