Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0000473 [Both Evo and DBA Classic] minor always 2017-02-15 07:59 2017-09-15 13:27
Reporter dwaldmann View Status public  
Assigned To JEMM
Priority normal Resolution fixed  
Status resolved   Product Version 2017.1
Summary 0000473: SO-A allows entry of non-existent Item Number
Description I thought I had reported this before, but can't find it anywhere.

We have "Allow new INs to be created in SO" turned OFF.
We have (still, working on getting rid of them) LPNs turned ON.
Can't think of any other relevant background.

If you enter a non-existent IN and press Enter, it goes to the (empty) Description field.
Press Enter again, it gives you a new blank line. Or,
If you Shift+Tab back, it skips over the IN field and gives you a new blank line.

In either case it creates a line with nothing except the IN in it.

If you save the SO just with the bogus lines, it says it has no open items do you want to close. If you say No, save it and re-open it, those lines are gone.

If you enter real items after entering a non-existent one, it saves a blank line. When you print an Ack, it inserts those blank lines. Pick Slips are not an issue for us, because we almost always only print lines with Ship Qty.
Additional Information
Tags No tags attached.
Enhancement Date 1484892000
Error Message
Program Name T7SOA
Repeatable in Test Company
Attached Files png file icon Screenshot 2017-02-15 08.56.56.png [^] (38,230 bytes) 2017-02-15 07:59
png file icon Screenshot 2017-02-15 08.57.12.png [^] (37,799 bytes) 2017-02-15 07:59

- Relationships

-  Notes
(0000761)
dwaldmann (reporter)
2017-02-15 12:33

I happened to see my post on the forum about the SO line grid and things started clicking. My bet is that this problem relates to LPNs. Because you don't actually enter the "ITEM NUMBER" in that field when you have LPN turned on. So probably there was no logic added for validating LPN and it lets you enter what you want, but then doesn't know what to do with it. So it disappears when you save the SO. Not sure why there's still a blank line there but that's irrelevant if you can't put it there in the first place.

If you find that's the case, I understand LPN is not being continued or supported, and that's fine. We have been in the process of converting back, it just takes a while.
(0000773)
ISTech (administrator)
2017-02-17 10:58

Currently running 2017.1 with all patches installed. Enhancement date on SO-A is 02/14/17. EVO version not classic version running. I was able to duplicate the issue to a certain extent. I don't have LPN turned on and as it has been disabled I can't not test that function with it on or off as it has been removed from even the defaults. That being said The issue when I tested it created a blank line NO part number just a blank line.

(0000822)
ISTech (administrator)
2017-09-15 13:27

currently running 2017.2 with all patches installed on 9/15/17
T7SOA.RWN enhancement date of 09/08/17.
could not duplicate issue.

- Issue History
Date Modified Username Field Change
2017-02-15 07:59 dwaldmann New Issue
2017-02-15 07:59 dwaldmann File Added: Screenshot 2017-02-15 08.56.56.png
2017-02-15 07:59 dwaldmann Enhancement Date => 1484892000
2017-02-15 07:59 dwaldmann Program Name => T7SOA
2017-02-15 07:59 dwaldmann Issue Monitored: dwaldmann
2017-02-15 07:59 dwaldmann File Added: Screenshot 2017-02-15 08.57.12.png
2017-02-15 12:16 ISTech Assigned To => ISTech
2017-02-15 12:16 ISTech Status new => acknowledged
2017-02-15 12:33 dwaldmann Note Added: 0000761
2017-02-17 10:58 ISTech Note Added: 0000773
2017-02-17 10:58 ISTech Assigned To ISTech => JEMM
2017-02-17 10:58 ISTech Status acknowledged => assigned
2017-09-15 13:27 ISTech Note Added: 0000822
2017-09-15 13:27 ISTech Status assigned => resolved
2017-09-15 13:27 ISTech Resolution open => fixed


Mantis 1.1.2[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker